contact contact

SUSE Linux 9.1 and Eloquence 7.0


Title: SUSE Linux 9.1 and Eloquence 7.0
Document: 1090923514
Author: Michael Marxmeier (mike@msede.com)
Keywords: Linux,SUSE

SUSE Linux 9.1 introduces a few incompatibilities that require patches or configuration steps as described below:
  • Eloquence versions before B.07.00 are not supported with SUSE 9.1.

  • SUSE 9.1 requires the Eloquence glibc2.2 build to be installed. Other builds seem to result in memory corruption, possibly caused by an libc incompatibility.

  • SUSE 9.1 defaults to the UTF8 (multi-byte UNICODE) character encoding.

    By default all programs (such as xterm or vi) output or expect UTF8 encoding of characters. However neither does Eloquence support UTF8 encoding at this point nor do commonly used terminal emulation programs.

    The workaround is to either set LANG (and possibly LC_CTYPE, etc) during login or use Yast to set the lang environment variable globally.

  • The eloqdb6 server fails to start on SUSE Linux 9.1.

    The solution is to install Eloquence patch PE70-0406240 or newer that fixes this problem.

    eloqdb6 was not compatible with the glibc2.3 library due to directly accessing the errno variable. This resulted in a warning on SUSE Linux 9.0 and a start failure with SUSE Linux 9.1.

  Privacy | Webmaster | Terms of use | Impressum Revision:  Mon Feb 24 15:35:21 2014  
  Copyright © 1995-2010 Marxmeier Software AG